DevSkiller Runtime Info

Programming task environments

Available programming task environments
Project type Runtime version Runtime components
name version
.NET Core with dotnet Default .NET Core SDK 2.2.105
.NET Core runtimes Microsoft.AspNetCore.All 2.2.3
Microsoft.AspNetCore.App 2.2.3
Microsoft.NETCore.App 2.2.3
.NET Core 3 SDK .NET Core SDK 3.1.101
.NET Core runtimes Microsoft.AspNetCore.App 3.1.1
Microsoft.NETCore.App 3.1.1
.NET 5 SDK .NET Core SDK 5.0.102
.NET Core runtimes Microsoft.AspNetCore.App 5.0.2
Microsoft.NETCore.App 5.0.2
.NET with MSBuild Default .NET 4.7.2
NuGet 4.4.1
Targeting Packs 4.0, 4.5.2, 4.6.2, 4.7.2
APEX Default Apex 7.74.1-32db2396ed
Android with Gradle Default Java 1.8.0_262
Android SDK Tools 26.1.1
Android 11 (API 30) Java 11.0.9.1
Android SDK Platform 30
Bash Default Bash 4.3.43(1)-release
ShellCheck 0.4.5
Bats 0.4.0
C/C++ with CMake GCC 10 GCC 10.2.0-13ubuntu1)
CMake 3.16.3
Google Test 1.10.0-3
Boost 1.71.0.0ubuntu4
Default GCC 8.3.0-6ubuntu1)
CMake 3.13.4
Google Test 1.8.1-3
Boost 1.67.0-13
Chef Default Ruby 2.5.0-p0
Bundler 2.0.1
Flutter Flutter 1.20.X Flutter 1.20.4
Dart 2.9.2
Go Default Go 1.13.4
Glide v0.13.3
dep v0.5.4
JavaScript with NPM NodeJS 14.x NodeJS v14.15.0
npm 6.14.8
Google Chrome 86.0.4240.183
PhantomJS 2.1.1
NodeJS 12.x NodeJS v12.13.1
npm 6.13.1
Google Chrome 78.0.3904.108
PhantomJS 2.1.1
NodeJS 10.x NodeJS v10.14.1
npm 6.7.0
Google Chrome 73.0.3683.86
PhantomJS 2.1.1
Java with Gradle Java 11 Java 11.0.2
Java 8 Java 1.8.0_191
Java with Maven Java 11 Java 11.0.8
Maven 3.6.3
Java 8 Java 1.8.0_201
Maven 3.6.0
PHP with Composer or Phing PHP8 PHP 8.0.0
Composer 2.0.8
Phing 2.16.3
Chromium 86.0.4240.111
PHP7 PHP 7.4.14
Composer 1.10.19
Phing 2.16.3
Google Chrome 87.0.4280.141
PhantomJS 2.1.1
PHP5 PHP 5.6.40
Composer 1.8.5
Phing 2.16.1
Google Chrome 74.0.3729.157
PhantomJS 2.1.1
Puppet Default Ruby 2.5.0-p0
Bundler 2.0.1
Python with setup.py Python 3.8.X Python 3 3.8.6
pip 20.2.3
setuptools 50.3.0
Default Python 3 3.6.9
pip 9.0.1
setuptools 39.0.1
Ruby with Rake Ruby 2.7 Ruby 2.7.2-p137
Rake 13.0.1
Bundler 2.1.4
Ruby 2.6 Ruby 2.6.4-p104
Rake 12.3.2
Bundler 2.1.4
Ruby 2.5 Ruby 2.5.0-p0
Rake 12.3.0
Bundler 1.17.1
Ruby 2.3 Ruby 2.3.3-p222
Rake 10.4.2
Bundler 1.17.1
SOQL Default Soql 7.74.1-32db2396ed
Scala with SBT Default Java 1.8.0_262
sbt 1.3.13
TERRAFORM Terraform 0.13 Terraform 0.13.5
iOS with Xcode Default Xcode 12.0.1

External components

Available external components
Name Version
Cassandra 3.0.9
Couchbase 6.6.0-7909
Elasticsearch 7.8.0
Ganache 2.13.2
HSQLDB 2.4.1
Kafka 2.1.1
Microsoft SQL Server 2017 (RTM-CU5) 14.0.3023.8
MongoDB 4.2.0
MySQL 8.0.17
Oracle XE 11.2.0
PostgreSQL 11.5
RabbitMQ 3.8.9
Redis 5.0.5

Security certifications & compliance. We make sure your data is safe and secure.